7 comments on “OCS 2007 R2 Front End Server Deployment

  1. I am getting ready to call it a day, but I was wondering if you have any clues for me.

    I am installing Office Comm Server R2 2007 in my test environment with Exchange 2007.
    Here is some notes on my environment:
    – Front End Server is on its own server
    – Edge Components are on a separate server from the Front End Server
    – All of the Edge services are started
    – On the Front End Server, my Front End service and my IM service will not start
    – Both are configured to use the RTCService account
    – I have changed the password to this account, checked to be sure it is in the correct groups- Still no help.
    – I am about to go crazy.

    Do you have any ideas for me? Also, the Adprep stuff was successful. Like I said, the only two services that will not start no matter what I do are Front End service and IM Conferencing service.

    • What kind of errors are you getting in the event log?? I have seen issue with the Front End if there is a configuration error.

  2. Thanks for this. You’re guide was a nice insight into the steps needed to do the migration.

    One typo you should consider fixing is the SearchBaseDN syntax. It’s dc=domain,dc=com, your example has domain,dc=com.

  3. Invalid action error:

    C:\MigrateOCS>cscript MigrateOcsGlobalSettings.vbs /Action: MigrateServerDnRefer
    ences /SearchBaseDN:dc=ipigroup,dc=it
    Microsoft (R) Windows Script Host Version 5.6
    Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

    Forest Root Domain: ipigroup.it
    Root Domain DC: ITNAT05.ipigroup.it
    Forest GC: itnatdc.ipigroup.it
    System Global Settings ADsPath: CN=Microsoft,CN=System,DC=ipigroup,DC=it
    Configuration Services ADsPath: CN=Services,CN=Configuration,DC=ipigroup,DC=it
    Schema Major Version: 1007
    Invalid Action
    Usage:
    cscript MigrateOcsGlobalSettings.vbs

  4. Hi ,

    I have a little tricky environment.
    The OCS 2007 servers are not in the root domain, but in a child domain.
    Every time I run the:

    Update DN References to the Global Settings Tree. At a command prompt, type the following command, and then press RETURN:
    cscript MigrateOcsGlobalSettings.vbs /Action: MigrateServerDnReferences /SearchBaseDN:
    Where server search base DN is the migration scope for servers.

    I’m getting – invalid action…
    Any ideas?
    Thanks !!

    • All the documenation is wrong, take out the space between /Action: and Migrate….

      /Action:MigrateServerDnReferences

      instead of

      /Action: MigrateServerDnReferences

      it should work then

  5. Wow that was unusual. I just wrote an extremely long comment but after I clicked submit my comment didn’t show up.
    Grrrr… well I’m not writing all that over again. Anyway, just wanted to say
    fantastic blog!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s